Exchange: Kostenloses SAN-Zertifikat bei StartSSL für Serverumzug

Problem:
Während meines Exchange-Server-Swings habe ich temporär ein zweites SAN-Zertifikat benötigt und wollte ein öffentliches haben, da sonst die Smartphones über ActiveSync Probleme machen!

Lösung:
Ich habe bei StartSSL ein kostenloses SAN-Zertifikat bekommen. Der Vorteil für mich, gegenüber von Let'sEncrypt", das Zertifikat ist ein Jahr gültig (nicht nur 3 Monate) und ich konnte eine CSR-Anfrage von meinem Exchange "reinkippen".

Nachteil:
Das Zertifikat ist nur ein Jahr gültig und wird von Apple als unsicher eingestuft (Nicht verwunderlich). Der Internet Explorer hat das Zertifikat als valid eingestuft, da hier noch die Root-CA als vertrauenswürdig gilt.

Als temporäres OWA- und SMTP-SAN-Zertifikat hat es für mich gereicht und hat auch super geklappt!

Franky hat hier eine super tolle Anleitung dazu gemacht (Wie immer!!): Frankys Web: Kostenlose SAN-Zertifikate auch bei StartSSL

...und StartSSL findet Ihr hier: StartSSL.com

Fehlermeldung: "Cannot initialize the snap-in" bzw. "Snap-In konnte nicht initialisiert werden" beim Öffnen einer MMC

Problem:
Ich hatte plötzlich das Problem, dass ich meine Exchange-Konsole nicht mehr öffnen konnte. Beim Öffnen kam die Fehlermeldung: "Snap-In konnte nicht initialisiert werden". Ein Neustart des Servers hat das Problem nicht behoben!

Lösung:
Das Problem konnte ich nach etwas Suche einfach lösen. Die MMC scheint Daten zu cachen und wenn es hier Probleme gibt, dann erhält man diesen Fehler. Man kann diese gecachten Daten einfach wie folgt löschen:

1.) Navigieren Sie zu folgendem Ordner:
bis Windows XP/ Server 2003:
C:\Documents and Settings\\Application Data\Microsoft\MMC\

ab Windows 7 / Server 2008:
?:\Users\\AppData\Roaming\Microsoft\MMC\

2.) Hier finden Sie Dateien, die wie Ihr Snap-In benannt sind. Diese Datei einfach löschen

3.) Danach lässt sich die MMC oder das Snap-In wieder problemlos öffnen.

Quelle:
Kaspersky: Cannot initialize the snap-in error in the MMC console

Exchange 2007: POP3 Logging aktivieren

Problem:
Wir haben einen Exchange 2007 bei dem der Dienst POP3 verwendet wird.
Ich möchte aber hierzu ein Log-File mitschreiben um eventuelle Fehler zu finden.
In der GUI lässt sich das Logging nicht aktivieren!

Lösung:
Hierzu muss man eine config-Datei anpassen. Bitte wie folg vorgehen:

- Datei C:\Program Files\Microsoft\Exchange Server\ClientAccess\PopImap\Microsoft.Exchange.Pop3.exe.config suchen
(Der Pfad ist anhängig vom Installationsverzeichnis von Exchange)

- Diese Datei mit einem Editor öffnen und den Abschnitt "appSettings" suchen

- hier den Eintrag add key=”ProtocolLog” value=”false in "add key=”ProtocolLog” value=”true” ändern

- Den Dienst "Microsoft Exchange POP3 service" neu starten

- Die Logs findet man unter: C:\Program Files\Microsoft\Exchange Server\Logging\Pop3

Quelle:
thebackroomtech: Howto: Enable POP3 logging in Exchange 2007

Microsoft Update über Konsole entfernen

Problem :

Microsoft veröffentlicht ein Update und zieht dieses wieder zurück, bei mir ist das Problem aufgetreten das dieses Update jedoch bereits über den WSUS verteilt wurde. Um jetzt nicht zu jedem Rechner zu gehen und das Update manuell zu deinstallieren ist hier der Konsolen Weg. Ich führe diesen Aufruf unter erhöhten Rechten im Loginskript aus wodurch mir das durch die Firma rennen erspart bleibt ;-) Hier z.B. das Update KB2982791

Lösung :

wusa /uninstall /kb:2982791 /quiet /promptrestart


Hier wird das Update KB2982791 über Konsole entfernt und nach dem entfernen nach einem Neustart gefragt. Lässt man promptrestart weg wird der Neustart einfach durchgeführt

Exchange 2007 / Outlook 2010 - Ihre Nachricht hat einige oder alle Empfänger nicht erreicht.

Problem :

Benutzer bekommt bei dem Versuch eine E-Mail zu senden eine Antwort vom Exchange Server das ein versenden nicht möglich ist.

Bild Fehlermail:



Lösung :

Im Internet existieren mehrere Lösungvorschläge zu diesem Problem. In meinem Fall konnte der Fehler nur behoben werden indem ich das Standardprofil des Mailclients komplett gelöscht habe um es erneut anzulegen. In der Systemsteuerung\Benutzerkonten das Icon E-Mail anklicken dann unter Profile das Default Profil löschen. Ein Tipp der bei mir leider nicht funktioniert hatte aber bei euch vielleicht ist den Exhchange Cache Mode zu deaktivieren anschließend die OFT Dateien löschen und den Cache Mode wieder aktivieren. Dannach werden die OFT Dateien neu angelegt. Ein komplettes Neuanlegen des Windows Profiles löst das Problem auch allerdings macht man sich mehr arbeit als nötig (musste ich schreiben da es auch als Tipp im Internet unterwegs ist)
“Das Alzheimer-Gesetz der Programmierung: Wenn du einen von dir vor zwei Wochen geschriebenen Code ansiehst, kommt es dir vor als hättest du ihn noch nie gesehen.”
Dan Hurvitz – Software-Entwickler