Samsung S4 Galaxy auf Android 7.1 flashen (LineageOS 14.1)

Man findet tausende Anleitungen wie man das unter Windows macht, aber keine wie man das auch unter Linux machen kann.
Davon mal abgesehen mein Windows 10 konnte keine Verbindung zum Handy aufbauen.
Immer wieder die Fehlermeldung "ERROR: Failed to access device. libusb error: -12" unter Linux hat alles sofort funktioniert.

komplette Fehlermeldung :
Initialising connection...
Detecting device...
ERROR: Failed to access device. libusb error: -12
Zuerst muss man überprüfen ob das USB-Debugging im Handy aktivert ist. Das kann man einfach unter
Einstellungen > Optionen > Entwickleroptionen
nachschauen. Solltet ihr den Punkt nicht haben dann müssen auch erst die Entwickleroptionen freigeschaltet werden, unter
Einstellungen > Optionen > Geräteinformationen
und dann mehrmals auf die Buildnummer tippen (denke 8 mal) wenn das erledigt ist noch das USB-Debugging überprüfen ;-)

Ich setze hier ein Linux System ein das auf Ubuntu 16.04 aufbaut, bei anderen Distros wird es ähnlich sein kann ich aber nicht grantieren ;-)

Zu Beginn installieren wir erstmal die heimdall Suite auf dem Rechner, das kann mit folgenden Befehl erledigt werden.
sudo apt install heimdall-flash heimdall-flash-frontend
Nachdem das alles installiert ist kann man dieser Anleitung folgen, es unterscheidet sich nicht mehr zum Windows.

Kleine Anmerkung zu der Anleitung von zdnet.de :

Zum flashen habe ich dem Befehl unter Linux lieber den ganzen Pfad gegeben.
heimdall flash --RECOVERY /home/username/download/samsung_flash/recovery.img --no-reboot
Nach dem drücken der drei Tasten [ Lautstärke nach oben ] + [ Home ] + [ Power ] erscheinen 3 farbige Zeilen oben links,
hier drückt und bleibt ihr NUR NOCH die [ Lautstärke nach oben ] dann klappt es mit dem Recovery.

Quelle :
http://www.zdnet.de/88290251/galaxy-s4-update-auf-android-7-1-1-mit-lineageos/

Natürlich seit ihr selbst dafür verantwortlich, bei mir hat es geklappt. Wir übernehmen aber keine Garantie !

Exchange 20xx - Gerätesynchronisation einschränken

Problem:
Man möchte die Exchange-Synchronisation von Endgeräten auf bestimmte Geräte beschränken

Lösung:
Ab Exchange 2007 ist es möglich über die Powershell nur bestimmte Geräte-IDs für die Synchronisation des Postfachs pro Benutzer festzulegen.
Hier die wichtigsten Befehle dazu:

# Zeigt die aktiven Geräte an und den Punkt "Device-ID"
 Get-ActiveSyncDeviceStatistics -Mailbox user123

# Setzen einer einzelnen DeviceID
 Set-CASMailbox user123 -ActiveSyncAllowedDeviceIDs DeviceID

# Mehrere Geräte setzen
 Set-CASMailbox user123 -ActiveSyncAllowedDeviceIDs {DeviceID1, DeviceID2, DeviceID3}

# Löschen des Eintrags damit wieder alle Geraete erlaubt sind
 Set-CASMailbox user123 -ActiveSyncAllowedDeviceIDs $null


Hinweis:
Sollte der Benutzer es trotzdem mit einem anderen Gerät versuchen, dann erhält er den Hinweis, dass dieses Gerät nicht für die Synchronisation zugelassen ist.
Außerdem wird im Ereignisprotokoll des Exchange-Servers der Eintrag "Blocked Device" angezeigt.

Quelle: msxfaq.de: EAS Absicherung
“Das Alzheimer-Gesetz der Programmierung: Wenn du einen von dir vor zwei Wochen geschriebenen Code ansiehst, kommt es dir vor als hättest du ihn noch nie gesehen.”
Dan Hurvitz – Software-Entwickler